今夜IT网

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 2014|回复: 1

[VmWare虚拟化] 虚拟机中被提示"请不要在虚拟机中运行此程序" 解决方法

[复制链接]
发表于 2014-3-4 14:49:08 | 显示全部楼层 |阅读模式
虚拟机中被提示"请不要在虚拟机中运行此程序" 解决方法.
英文提示:"Themida Sorry, this application cannot run under a Virtual Machine"
解决 VMware 虚拟机 中被提示 “请不要在虚拟机中运行此程序”或者“Themida Sorry, this application cannot run under a Virtual Machine”方法

自己发现问题,解决问题后,觉得应该分享给大家。

用记事本打开 VMX 文件 类似 Windows XP Professional.vmx

在文本末尾加入一行

monitor_control.restrict_backdoor = TRUE

保存文件

现在启动虚拟机 就不会被其他不能运行的软件检测到了

如果还被检测可以再加入一行

disable_acceleration = TRUE

“这样处理以后 可能有个后遗症 就是 VMTools 无法加载了”————
我的没有遇到这种情况

以上来自网络,未亲测
=======================重 -------- 点===========================
1原因:是因为此程序会自动执行虚拟机检测,从而禁止在虚拟机运行。
2解决办法:打开 VMware 虚拟机的配置文件,这是一个后缀为 vmx 的文本文件。在里面加入以下内容
isolation.tools.getPtrLocation.disable = "TRUE"
isolation.tools.setPtrLocation.disable = "TRUE"
isolation.tools.setVersion.disable = "TRUE"
isolation.tools.getVersion.disable = "TRUE"
monitor_control.disable_directexec = "TRUE"
monitor_control.disable_chksimd = "TRUE"
monitor_control.disable_ntreloc = "TRUE"
monitor_control.disable_selfmod = "TRUE"
monitor_control.disable_reloc = "TRUE"
monitor_control.disable_btinout = "TRUE"
monitor_control.disable_btmemspace = "TRUE"
monitor_control.disable_btpriv = "TRUE"
monitor_control.disable_btseg = "TRUE"

这段代码在7.0-7.1版本虚拟机好用.

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 官方QQ群

QQ|小黑屋|手机版|今夜IT网 (京ICP备11034012号) 

Powered by Discuz! X3.2

快速回复 返回顶部 返回列表